Release update shutting down while downloading data

I launched Skritter today and apparently an update came through because the limited portion of the UI that I can see is very different. It asked me to login to my account, which also is different. Anyway, as soon as I did that, it began a phase of ‘downloading data’ with the warning that larger accounts could take a while.

It’s been 4-5 hours. I let it download and walked away from it, but several times after picking it back up to check progress, the screen blacks out and the app apparently resets and begins downloading again, which tells me it’s shutting down when idle. I don’t have any power management programs running on my phone and I have Skritter registered with all the available exceptions to prevent interference from the OS, but it keeps shutting down during this data download. Yes, my account is very large. At this rate it could take several days to get through all this.

Any tips on how to speed up the process? Any idea how long it might take?

Hey hz,

Big changes indeed. We’ll try and load your account on our end and see if we can track down why the initial download is messing up. Nick’s account and my own account are similar in size and they’re downloading in around 10-minutes, which is a long time, but there’s a lot of data there. Not close to 4-5 hours though. I appreciate you sticking with it for so long!

@josh is going to dig into it and see what we can uncover. Out of curiosity, what country are you trying to download the data from? Shouldn’t make a difference, but just trying to get extra info.


@hz quick update

Your account is triggering some account timeout reports on our end and we’ll dig into them. My initial though it that some vocab id from the legacy server is refusing to return data for us. We’ll keep posting updates as we get them.

Another update :slight_smile:

Found the request that is crashing your download. We’re digging into the fix. Download time should realistically be sub-five minutes.

The issue was related to a word with a funky sentence causing things to silently stop downloading. I think I’ve patched the bug. Try downloading your account again when the next beta update pops up in the store. I’ll be releasing it in a few hours and it might take a few hours to show up on device.


I’m afraid I have the same problem being unable to download the account data on startup of the new Beta. Trying to download from Singapore. Have left it running all day/night several times on wifi.


1 Like

trying your account on the latest build right now to see if it works. If not, @josh will have to investigate further.

@DojiStar @hz your accounts will work on the latest update. I was able to load them both up on my build, which should be in the store soon. I’m pretty sure @josh had to disable some of the non-Skritter official sentences to make it work, but you’re not going to be alone in this bug and this is the fix. For now.

Hi. Still not working. Same behavior.

@hz just to confirm, you went to Skritter android app in the Play Store and there was an “update” button you could press and it’s still not working? I’m a bit ahead of you’re release since I’m on an internal build and it’s possible the latest update isn’t in the store just yet. Sorry if I wasn’t clear about that in my last post.

I’m on 3.0.1 (300022) on my device, btw.

No, I didn’t opt into anything. I had a batch of updates run simultaneously yesterday, and I assume Skritter was among them. Hasn’t worked since then, and isn’t working now. I’m giving up. Let me know if you find the problem.

@hz you are registered as a beta tester, which is why you automatically got the the update we pushed yesterday. Sorry it borked things for you. You’re welcome to opt out and go back to the current release version of Skritter or grab the apk file for 2.3.5 (the latest version you were using here:

That said, you can check for the fix, which I can confirm on my end, by opening My Games & Apps in the the Play Store. Navigate to BETA once that is open and you should see the Chinese app there. Click to open the app, and if 3.0.1 (300022) is out you should see the “update” button, otherwise it’ll show “open” if you’re already on the latest. We pushed it already, but it can take hours to roll out on all devices from Google Play, so I have no way of knowing what you’re seeing without you checking. Sorry.

If the update is there the app should be fixed. Or you can wait for the next batch of auto updates to appear on your device and give it a go then. Obviously, if it doesn’t work we wanna know about it so @josh can take another look tomorrow. But, as I said in my last post. I loaded up your account on the latest version I could access and it loaded up in less than 10 minutes.

Thanks, working now, the DL was pretty fast!

1 Like

Glad to hear it, @DojiStar!

I did a walkthrough video of the app on YT and posted up some notes here if you feel like hearing me ramble about the new stuff, known bugs, etc.

Looking forward to your feedback so we can continue to improve the app!

I found another update today. I didn’t mean to suggest that I wasn’t signed up for the beta test; I did opt in for that. Just meant I didn’t go on my own initiative looking for updates yesterday.

I’m into my account now, but it says I have 5500+ items due for review, which is untenable. New problem.

I think part of the problem is it’s giving me definitions and reading counts. I checked my study preferences and they’re all correct: tones and runes only. But when I open the study queue it’s asking me for definitions. Probably this is affecting the overall count. I hope so, anyway.

Glad it loaded up! And… another issue. Dang!

The issue reported is most certainly affecting the overall count. We didn’t see any of this during our internal testing, but we’re aware of the issue and it is one of the highest priority things on the list for now. We’re digging into a fix for you and users in a similar situation.

In the meantime, I’d like to suggest trying to use filters (top-right icon on the study screen) and toggling definitions and readings to off for now. They’ll still be “due” on the dash (they shouldn’t be at all), but they at least shouldn’t bother you while you review.

It’s been a super long day and I’m calling it for now, but @josh will be back on attacking bugs again tomorrow morning and we’ll keep the updates rolling out.

Gah. It’s reading to me too. How do I get it to shut up?

I found a separate control for readings and definitive. That seems to have reduced the count. I really need to find a way to turn off the voice though. It’s embarrassing trying to study in public.

1 Like

Volume off or mute button? We clearly need an audio off button. Gah indeed.

This post was from my phone so it doesn’t count as work. Haha. We’ll get you and everyone else sorted as soon as we can. Just went from one main tester to a bunch, and you’re all doing a great job of spotting all the bugs and issues I missed. So thanks and sorry to cause frustrations!

I seem to have a smililar problem on my account with Skritter Japanese. On both my Android phones (one is Android 7.0, the other is Android 8.0 with plenty of RAM), it will start downloading at about 20-30KB/s (according to the graph in NetGuard) for not more than a minute, and then just crap out. I noticed that the Storage permission was turned off (and I was not prompted for it when I opened the beta for the first time), but turning that permission on makes no difference. Rebooting the phones, reloading the app, closing all the other apps… same behavior every time on both phones.