Chinese app iOS 12 taps not working


I noticed that after the iOS 12 update, finger taps of the panel in the regular Chinese app are not working well.

Specifically if I want to go back to the previous word, or try to toggle forgot/so-so/correct at the bottom of the page, it takes up to maybe five to six taps of the location on the screen until the desired action is carried out.

It seems as the control is frozen for a while.

Any ideas on how to fix? It’s useable but a bit annoying.

Thanks in advance.

We’re looking into a fix for this, sorry for the inconvenience!

1 Like

I also have the same issue.
However, this issue was in the app before I updated my phone to iOS 12.

Sorry taps aren’t working well. We’re seeing the same issues and understand the frustrations. While we’re looking into a fix, we’re also working on getting our Skritter: Write Japanese app into the App Store as quickly as possible. Japanese students (who aren’t on the beta) on iOS can’t study after they upgrade to iOS 12, so we’re working on fixing that first.

We’ve been working with Apple for months but still can’t figure out why the app is getting rejected on our end. We’ve been working on an updated version for about a year now (the current iOS beta) and are putting nearly all efforts into getting the Japanese app out as soon as we can.

After that, we’ll shift focus on making Chinese gets the same love and attention it usually gets. Having this issue solved should also let us really focus in on making sure things work as intended and help all of you maximize your study experience!


P.S. If you’re so upset about this that you’re considering walking away from Skritter, please do talk to us first. We’ll do what we can to help make it right. We really wanna fix all the issues, but we only have so many resources at our disposal.

Appreciate the comments above. Just adding my experience in case there was a fix that I wasn’t aware of. I’m experiencing similar tapping issues

I’m not sure how I missed this, sorry for the delay! The tapability issues are still there unfortunately, but can be worked around. It seems like the tappable areas have shifted a bit. If you tap more towards the canvas for the navigation arrows, and more near the bottom for grading buttons, it seems to react a bit better. Sorry for the inconvenience.

It’s not just going back to the previous character that is problematic. If you try to “double tap” to completely reveal a character that you’ve forgotten, you might end up tapping the silly screen 20 or 30 times before getting the reveal (or before you give up in frustration). The built in gestures are a nice idea (assuming they worked), and I can see how they’d clean up the interface, but honestly I’d much rather have some dedicated buttons for forward, backward, hint and reveal that were always displayed if they would actually work reliably. The current finicky interface can be extremely annoying.

1 Like