Conflict with existing vocab

Hi, I’m adding some words in a new list and one expression, maybe it’s slang, I don’t know doesn’t want to be added. I get the error:

Blockquote
{“readyState”:4,“responseText”:"{“message”: “Conflicts with existing vocab.”, “statusCode”: 409, “error”: “APIResourceConflict”}",“responseJSON”:{“message”:“Conflicts with existing vocab.”,“statusCode”:409,“error”:“APIResourceConflict”},“status”:409,“statusText”:“Conflict”}

I’ve messed around with the pinyin and traditional characters options but it doesn’t want to work.

What is the expression you’re trying to add?

It’s 童颜巨乳

Don’t read it if you are under the age of 18.

I see this problem all the time when trying to add new words. So much so, that I quit trying to add new words to the database. You try to add something, and it tells you that it cannot add the item (you get some JSON error). Then you take the time to try to add it again and it fails with the JSON error above or something similar.

I now know you can go to the legacy site and look up a word in the database. This particular word appears TWICE? Not sure why a word can be there multiple times.

But, @eenmarco, your word is already there. Not sure if it was your addition or somebody from earlier.

That’s my definition allright. Maybe it got added with some delay or something. I’ve just added it so this bug solved itself! Very good!

Also thought this word would just go into my personal database of words, but looks like it’s on the global list. So I’ll add it with english definition next time, thats a bit more user friendly.

Curious, I rarely get problems when adding new words to the database, and I add about a dozen a week or so.

I use the legacy mobile app to add words to new lists, because it is the only way (so far as I know) to add new words to the database.

Then I switch to beta app for study (although I am still waiting eagerly for individual character sounds within words to make it into the next set of beta improvements!)

Is there a different way to add words not yet in the database?

I add them on the skritter.com website, just edit the list.

The web version (new Website, not legacy…haven’t tried adding new words via legacy Skritter site) let’s you add words. I use Simplified Chinese, so enter the characters in Simplified. However, if there are traditional variants (which I usually forget to check), when you try to submit, you’ll get an error saying you have to specify which variant. However, regardless of which variant one selects, it appears the character was already added, because you’ll get another JSON error.

It’s also frustrating that you have to put “numeric” PinYin in, instead of “real, accented” PinYin, because if you look up words in apps such as Pleco or Google translate, you get “accented” PinYin. Typing out numeric PinYin is a pain.

Try using legacy mobile to add words to database.

Still have to use numerical, but otherwise no problems.