Constantly repeating the same review

The latest update sorted the problems I was having with responsiveness and crashing, so that’s good.

Unfortunately, I can’t make progress because one of my reviews just repeats over and over. I’m studying traditional, but the review for 相處 shows up in simplified and just repeats over and over. My review list is almost 2000 long (mainly due to being very busy the last couple of months), but normally I could work through it in a couple of days hard work. Currently can’t even make it through ten in a day though.

Thanks for the report! I have gotten a few other reports of things getting stuck on a loop of a particular character or work. I’m going to be doing a bit of investigating today and hopefully a fix in the next build.

Is there any update on this? I still can’t study for more than 5 minutes or so without getting into an endless loop. Tried signing in and out and clearing data/cache.

If you’re using 3.0.11 and still seeing this loop there isn’t much of an update. But we are still aware of people experiencing this issue and are still working on making sure it doesn’t happen. Are you still seeing the simp on your trad account?

It’s hard for me to say because I can’t get through more than 5 or 6 characters. The ones I’m seeing are traditional, but they were last time as well except for the one. Can you give me a link to the old app? At the moment I can’t study at all.

Could you let us know what cards you’re seeing the loops on? The items that are looping and the card types are really helpful for us trying to figure out and identify patterns.

APK files are all linked here:
2.3.5 for Chinese and Japanese are the last major updates we did for the older beta version.


Sure. The first time happened with 相處, but it appeared simplified. Now it’s happening with 盡頭, which is appearing correctly as traditional.

Be sure to check out 3.0.12 when it drops. Josh has been working hard to fix loops and this is the first build that really attacks them. Our fingers are crossed!

1 Like

Tried it last night for a half hour and it seems to be resolved. Will test more extensively over this week, but fingers crossed.

Thanks for all your hard work, the app has really improved in the last month!

1 Like

We’re glad to hear it. Our fingers are crossed as well!

I’m getting this in the latest Japanese version. I get the word correct, but the same task for the same word pops up again forever. I can add new words, and it will give me those, but once it gets back to the word I was stuck on it gets stuck again. It’s happened on multiple different words. iOS beta 3.0.18.

This seems to be related to Japanese kana and we’re working on fix that will hopefully be included in the 3.0.19 patch.

I’m encountering this as well, is there any update?

I got the beta because the old app crash loops for me, but it looks like I can’t use this beta either.

What I’m seeing:
(For those who are curious, this is what I used to see:

The next update (coming soon) should hopefully take care of this, items are being treated differently. In the meantime, does banning 可愛い sort the loop out?

No, even after banning kawaii, other words caught the same bug. However, turning off kana did.

(That said, after posting this, I reset my progress and restarted with just single kanji cards, so this isn’t affecting my usage of the app anymore.)

1 Like