Do Mnemonics exist on Android?

I’ve noticed that pre-popullated mnemonics don’t show up on Android like they do on iOS. Looking at past forum posts, it sounds like it worked in the past at some point. Does it work for others and just not me? I’ve tried uninstalling/installing.

Seems to be an issue on both the phone and the Nexus 9.


If you’ve previously selected or written a custom mnemonic for a specific character or word then it should show up on the extra information panel. If not, then you’ll see the box where you can enter a custom mnemonic. Right now Android doesn’t support selecting other users custom mnemonics.

Thanks for the information. Please add that to the top of the feature request list! The mnemonics that show up from other users is perhaps the #1 gap between Android and iOS in my usage. Super useful and efficient when learning characters.

Editing the mnemonics on Android still doesn’t work properly. My mnemonics appear (great!) with the “ADD mnemonic” button (should be “EDIT”) to the right. When I click on that I get to an ~edit~ window where I can apparently edit and click “save”. However, this returns me to the info page with NO mnemonic (the one I just edited is gone) and the choice to add again. I can then add one…
Any changes I make on the web version work fine and are reflected on the android version so the database is accessed properly on android but the editing on android is frustratingly difficult because of this bug.

Hey @sarac, I just checked it out and something wonky is definitely going on when trying to edit an existing mnemonic. Actually I know the fix for it and have added it to the list of things to fix for the next update.

I just spent a day studying and adding mnemonics on Android only to find they have all disappeared. I looked through this forum just to find that the same problem with mentioned in July 2015 and that the developer had a solution for it. So disheartening.
Entering the mnemonics was wonky enough as the back space button takes out the letter second to the left rather than the one immediately to the left. Then the same letter is added twice when entered once after using the back space.
But now I’ve lost all the entries that were there yesterday. I feel like throwing a temper tantrum!

@Chrysmc I’ve added an extra week to your subscription in hopes it might deter any potential temper tantrum! Are you sure your mnemonics are actually missing? You can check by going to, and then searching for a word in question, clicking on it, and then checking the mnemonic information in the pop up.

The new Android beta client just came out, so your timing is perfect! Here’s a link with more info:

Hi Jeremy,
Thanks for the response and the extra week. I appreciate it.
The temper trantrum is still brewing though as the mnemonics show up on my surface pro but not on my android Oppo f1 phone. And I can’t write on the surface pro, in either tablet or desktop mode, but can on the Oppo.
I’ll take a look at the beta client. Thanks.
Kind regards,

1 Like