Error loading next word

Today, using the web version of Skritter on mobile, I encountered a bug wherein the app would fail to load the next word after I’d written the current one, starting after I’d gone through a few words.

I tried using the web version of Skritter on desktop and encountered the same problem. The error is triggered when I click on the right-pointing arrow to go to the next vocabulary item and the JavaScript console reports that this.getVocab is undefined. The minification makes it difficult to determine what this is in this context.

Here is the stack trace (with the full urls shortened to circumvent the link-posting limits):

isCharacterDataLoaded application.js:33
n application.js:1
c libraries.js:46
aa libraries.js:47
l libraries.js:48
Js libraries.js:47
Ao libraries.js:47
h libraries.js:46
Ao libraries.js:47
J libraries.js:46
Ao libraries.js:47
ra libraries.js:47
getNextLoadedUserItems application.js:1
next application.js:43
handlePromptNext application.js:43
i libraries.js:47
f libraries.js:1
M libraries.js:1
p libraries.js:1
trigger libraries.js:1
next application.js:5
handleClickNavigateNext application.js:6
handleClickNavigateNext self-hosted:1003
dispatch libraries.js:37
handle libraries.js:37
i libraries.js:61

The browsers involved are Safari on iOS and Firefox 69.0 on MacOS.

1 Like

Hi @Undul8ion, we appreciate the report. Is the behavior consistent? Is there a certain list you were studying when you ran into the bug? Had you just started studying or been studying for a while? Thanks!

Hi Michael,

It was consistent on the day that I wrote this report, on both browsers. It always happened a few words into the practice (I was doing default practice through the big green “study” button). However, I’ve just tried to replicate the bug and was unable to.

Since the browser version wasn’t working for me, I downloaded the iOS app and have been using that. Maybe something about the sync process reset some internal data? I know that’s not very helpful but on the plus side every version of Skritter is working for me now.

Thanks!

1 Like

Glad to hear. I don’t see any logs indicating the type of error you were experiencing or service interruptions, so maybe it was just a weird server/internet hiccup? In any event, if you’re using iOS, make sure to try out the new Skritter: Write Chinese/Japanese apps, that’s where all our active development is concentrated!

1 Like