How to stop it from adding KANA only word to reading mode

I dont know if i ever used reading mode with japanese. But there is no point in asking the reading for a Kana only word. Especially because i have romaji turned off.

How i can stop these from being added?

ps: also why can i not type hiragana like typing pinyin instead of having to check it myself?

This is something we intend to implement but haven’t gotten to quite yet.

This is a good point. If you have romaji disabled, it makes sense to not have reading cards for kana only words. It looks like we have improvement notes for this.

there is an open source non copy left api for that on github!