Issues with drawing via touch or pen in Chrome 70


This is an issue I am having with Skritter web. After updating to Chrome 70, I found that drawing characters with the stylus on my Surface Book no longer worked. Neither did touch. These had been working in past versions of Chrome, and work in Firefox.

I believe it the problem is related to this Chrome change which was released in version 70:

I went in to chrome://flags and set “Touch Events API” to “Enabled” (the default is now “Disabled”), which allows me to use Skritter with pen/touch again, so it seems likely that this change is the culprit. There are some suggested changes in the chrome page on how to detect touch screens.



This was just in time for me to install Chrome on a new Surface and hit this issue. Thanks!

Prior to this I gave Edge a try, just because MSFT is often more focused on pen/touch input than everyone else. Unfortunately the Skritter canvas in Edge has the same issue you described with Chrome. If you use the pen normally you get dragging. You can write if you hold down the button on the stylus, but that’s super annoying.



On-screen writing suddenly totally stopped working on my Surface no matter if I use Chrome, Firefox or Edge, and regardless of whether I use the stylus or my fingers. Fix needed urgently. Has nothing to do with a Chrome update IMO.



@afarnsworth suggested fix worked. It is weird, as the issues are the same in Edge so it should not be browser related.


closed #5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.


unlisted #6