"Mark as learned" not working


The word 果断 has been stuck in learning mode on my app for almost a week now. Every time I mark it as learned, it just shows up there the next day again.

Some other observations –

  1. If i click “mark as learned” and then immediately exit learning mode, the word is marked as learned in the deck view.
  2. If i then enter and immediately exit “learning mode”, it is marked as unlearned again.
  3. If i then enter “learning” mode again it is the first character to learn.

Another interesting learning mode failure, probably the same issue:

  1. I entered learning mode and marked guo3duan4 as learned. After that, i learned yao2yan2 (rumor). Then I exited learning mode.
  2. Immediately entered learning mode, next to learn is shi1wu4 (mistake).
  3. Immediately exited, entered (still shi1wu4), exited, and entered again. This time, guo3duan4.
  4. Clicked “mark as learned”, and then the next screen is for yao2yan2 again!

Thanks for your help. This is with 3.4.1 (300389) of the beta on Android 9.

It sounds like the word is getting optimistically marked as learned, but then isn’t actually getting saved to the server. Which deck are you experiencing this issue with?

This is with the HSK6 deck! I’m going to redownload the app and try again, I’ll update you on whether this continues to happen.

Let me know how it goes. If you haven’t tried it already you could “Refresh Local Data” from account settings screen. That essentially downloads a fresh copy of all your reviews and then the next time you enter a deck it does a fresh download of that as well.

I’m having the exact same problem, exactly as described above. I’m using the android app (version 3.4.1).

Every single time I mark a word as learned, it pops back to unlearned within a few seconds of exiting learning mode.

I have tried:

  • refreshing my local data
  • closing and reopening the app
  • logging out and back into the app
  • force syncing the deck
  • uninstalling and reinstalling the app
  • completely resetting my account and progress

None of these have worked for me. At this point, the app has become quite literally unusable, as I cannot mark a single word as learned, and thus my reviews remain empty.

Let me know if there is anything else I can do to fix this issue.

@caitlinf We’ve sent you an email!

This seems to be fixed for me now, after reinstalling the app and logging in I no longer have the problem. I wish that weren’t necessary but at least it works now. Thanks for the suggestion!


I had the same problem, and wrote to SkritterJake about it. I don’t know what he did, but the problem is gone now.

This is now happening to me again with 后顾之忧 in the HSK 6 deck. Still Version 3.4.1 300389.

@VIRTUALDOG Ugh. Sorry that you’re experiencing these issues at the moment. I just loaded up your account on my device to have a look, and I’m seeing 后顾之忧 correctly marked as learned on the deck. Also, when I look at this particular item on the website it does appear that it is ready for review.

I should note that I’m looking at your account on an internal build that we’re getting ready for a beta release so it is possible that we’ve actually patched up whatever issue you’re seeing in our latest build. Another possibility is that the fresh log in is what has marked this item as learned.

Not exactly sure what the heck is happening, but I’ll try on the same build as you with some of the reproduction steps you’ve mentioned above using a test account and see if that reveals anything. I’ll do the same on the internal build we’ve got as well just to make sure I’m not missing anything.

@VIRTUALDOG Quick follow-up question. Any chance you’re using the back button to exit out of a learning activity?

I actually had a similar problem with the Japanese app back in September last year. (I meant to report it together with some other issues but I was busy and then I stopped adding new items and forgot about it.)

One thing that I noticed was that the issue was deck dependent. So instead of using the already published Genki textbook deck I made my own lists and could add without problem. Adding the previously dysfunctional items from my own list successfully marked them as learned in the broken decks.

Don’t know if this is the same issue, but since I didn’t say anything back then I figured that I should at least mention it now.

1 Like

I make all my own decks and still experienced this on a couple of words a few weeks ago. But somehow all resolved now.

Well, someone made the lists that I was trying to add from, so presumably it could have happened to any of the lists I created too. Perhaps it would at some point, if I hadn’t stopped adding Japanese words so soon. We will probably never know. Anyway, what I wanted to say was that it wasn’t a word issue, but rather a word in a specific list issue.

1 Like

If you’re still running into this please shoot us an email at team@skritter.com!

Yep, it has happened again. Sent you an email.

1 Like

@Therebackagain Apple just approved our latest build build and it should fix this issue :crossed_fingers::crossed_fingers::crossed_fingers: Give 3.4.2 (300394) a go when you can!


1 Like

Sorry for the late reply @SkritterJake. Yes, I usually use the back button to exit learning mode. This is still happening to me. If there’s a new build on Android I haven’t gotten / tested it yet.

This has persisted for the last ~10 days. I have just been working around it and not paying too much attention it, so I don’t have anything new to add.

Sounds like the problem I had. I ultimately gave up using the app after multiple emails sent and different solutions tried. I wonder if it’s tied to some sort of Android app backup setting.

We’re digging into this and hope to figure out what’s causing this soon