Microsoft Surface for writing characters

Hello Skritter Team

I bought the Microsoft Surface with the intend of studying chinese faster using Skritter.I’m now deeply dissappointed by the website. I can’t use the touchscreen to write the characters but instead have to use my trackpad or mouse to do so. I would love to see that fixed soon cause I’m having an exam in the near future.

Kind regards
Sidney

Hi Sidney, glad to hear you’re excited to learn some Chinese with us, I hope we can help you out! I love using my Surface to Skritter, it’s probably my favorite device to study on. I just checked and both the pen and touch input worked for me on https://skritter.com in Chrome v76, Firefox v69, and Edge v42.

Which Surface model are you using and what browser? We recommend you install all the latest Windows and browser updates and Surface firmware.

Hello, I have the same issue (I reported in the feedback sessione, shame on me that I haven`t see this topic earlier).
I have a Surface 6 with Edge 42 and Chrome 76 but the pen input does not want to work :frowning:
Maybe I need to install some extensions or xxxplayer?

Hey @116, sorry it isn’t working for you. You shouldn’t need to install any extensions to use Skritter, it runs on regular web technologies.

I just tested pen and touch input on Chrome 76 and Edge 44 and didn’t have any problems. Are you only having problems with the pen input or both pen and touch input (e.g. when you use your finger to write)?

1 Like

I can’t use neither the pen or the touch. When I try to write nothing happen, except that it gives me the hint for the stoke.
Here a 30s vid that may be explain better:

1 Like

Thank you for the video, it helps to explain a lot. Is your Surface in tablet mode? I noticed when I set mine to tablet mode I got similar problems, but when it was in normal laptop mode the writing worked fine (Windows usually asks me if I want to switch between modes when I take off the keyboard or put it behind the Surface so it looks more like a tablet).

Hi Michael, sorry for my late reply… Actually I do not use the tablet mode at all.
So basically I still can’t write either mode :sweat_smile:

Hi, sorry for my late reply too, somehow I missed the notification. Have you tried pressing the “click” button at the bottom of the pen when you write? On some newer Surface models the default pen behavior is different and requires you to explicitly click for input to be recognized. I had to do that when using a Surface Pro 6.

Apologies for reviving an old thread, however I am experiencing similar issues.

I have a Surface Go (unsure of exact model, but bought in July 2019) and I was having the same problem. At first, pressing the “click” button solved the problem and I could physically write the kanji with my Surface Pen.

However, some words later the “click” button stopped having any effect and was acting like I had right-clicked. This could simply be me not knowing the finer points of how to use a Surface Go, but I would be very grateful if anyone could advise me on how to get the pen working with Skritter again!

Edit: I refreshed the page and it started working again, and then after a few characters it was back to not writing again!

Hi @BIRBLORD, congrats on your new purchase! What browser(s) are you trying to Skritter in? My first stop would be the Pen & Windows Ink area of the control panel, see if changing the options around in there improves your experience.

1 Like

Thank you for your reply! I am using Google Chrome version 77. I have turned off press and hold for right-click and pressing the button nearest the nib for right click - neither of these have helped. I am not an expert, but I’m not sure what other settings might assist.

Unfortunately, I don’t have immediate access to your model of Surface, so while I can’t say for sure how to get it working on your device, I am fairly confident it should as there are multiple other pen and touch devices for which Skritter does work in Chrome (including different models of the Surface line). Try searching the internet for pen input issues in the browser with the Surface Go. Make sure you’re not in tablet mode, have the latest Windows updates and device firmware (both for the Surface and the Pen), and in general play around both with the pen and its settings (try writing without holding down any buttons, with clicking, with holding down a button, etc.). The default Pen behavior varies by generation and various Windows updates over the years which makes it hard to pinpoint exactly what settings make it work best in the browser.
If you do discover some insights, please report them!

1 Like

Hey @BIRBLORD, in another thread, a user discovered a workaround for Chrome. Perhaps this will help you too? Surface Pen only working when Clicked

1 Like

Hi, I’ve been having this issue eversince I tried to use my Surface Pro 3 (with my finger) and my Wacom Cintique 13HD.
Both my Windows, my drivers, and my browsers are updated. I’m using Chrome by the way.
I also had everything set up as written here.

I’d suggest adding the settings below to the official list here:
https://legacy.skritter.com/wacoms/settings

Solutions:
Wacom: what made it work for me was this indeed.

  1. Copy-paste this into the Chrome address bar: chrome://flags/#direct-manipulation-stylus
  2. In the drop-down menu that displays Default change it to Disabled.
  3. Restart Chrome.

Surface Pro: similarly to the Wacom solution, another flag needs to be enabled in Chrome flags:

  1. Copy-paste this into the Chrome address bar: chrome://flags/#touch-events
  2. In the drop-down menu that displays Disabled change it to Enabled.
  3. Restart Chrome.
2 Likes

I’ve just run into this issue, and I couldn’t find the direct-manipulation-stylus flag in chrome anymore. I think they might have removed it in a recent version.

I’ve been able to fix it though with the following userscript (which you can use with tampermonkey. https://pastebin.com/gMLwx8ZJ

It simply passes any touch events as a mouse event - which fixes the stylus for me, but it also allows you to draw the character with your finger, which may not be ideal.

4 Likes

Thanks Luke, how did you find out about this script?

weirdly references to direct-manipulation-stylus still appear in the git page for chromium, though it seems to no longer be available in chrome or edge-chromium.

maybe it’s “expiry_milestone”: 76 :frowning:

1 Like

it is probably worth bugging it to chrome / ms. This was a very useful feature up until now.

Thanks Luke, how did you find out about this script?

I wrote it myself. Got annoyed with Firefox’s pen support (it’s a bit glitchy), and opened Google Translate in Chrome, and noticed that their handwriting recognition worked correctly with the pen input, so looked through their page to see any differences between them and skritter.

Google Translate had event handlers for the touch start, end and move events (as well as mouse events), whereas skritter was only handling mouse events. I wrote that script based off jQuery’s touchPunch - which essentially listens to touch events, and then triggers fake mouse events in response to them.

it is probably worth bugging it to chrome / ms. This was a very useful feature up until now.

Looking through https://github.com/Microsoft/vscode/issues/36492, it looks like Microsoft has purposely introduced the pen as touch change (as opposed to pen as mouse as it was previously), and doesn’t really want to change it back. Could bug chrome to re-add the direct-manipulation-stylus flag, but I think it’s probably best to try to add the appropriate touch handlers within skritter.

1 Like