My Beta Feedback Thread

As with others, I’ll add small posts here as I notice things.

  • Auto advance: I like that you can stop this with a tap and then swipe up as in Old Skritter to re draw the character. However, after re draw, it attempts to auto advance again. I think once auto advance is stuck for a character, you should be in manual mode for that character until you choose to advance. Explicitly advancing can then re activate auto advance.
  • As noted in another thread, Quick Test doesn’t work for me. It never saves the words I add to the list. The whole UI here feels weird and unfinished. It would be nice to have a “Start Test” button or something at the bottom of the word list to initiate study of the current list.
  • I wish the display of the lists on the front page showed the current progress as a graphical bar like the old list view on old Skritter does. I like having a view in one shot of how far I am along in my various lists. I started over after a long break, so I’m adding words from seven lists (radicals, JLPT 5 to 1, and my own custom word list).

In general, the app is a great improvement! I like the modern look and feel and the higher res UI.

1 Like

I also miss the feature where the current term was copied to the clipboard. This made it easy to pop into Midori, which supports clipboard auto read as a feature, and get more details on a word.

It’s totally weird and unfinished :slight_smile:

We were using “quick test” to make sure adjustments made to the writing canvas were working as intended, and we left it in as something to develop over time. It most certainly needs a big button at the bottom and a bunch of other stuff. We’ll probably work on improving things over the next month or two, but other app functionality will take precedent (stats and lists for example). One idea we’re toying with internally at the moment is having the ability to “quick test” a list section using this feature. With that said, here is how it should be working, along with some screenshots to give more context

Launch “quick test” and tap to add your first word.

Type or write the character(s) for the word and press return. If it doesn’t load the full word press return again and it should appear (one of the things we need to improve)

Once you have a few words in the queue, press the “X” button on the top left (again, needs improvement) and the quick test should begin.

Items you’ve added to the list should appear in the order added and restart from the top when you’ve done them all. If you want to add more words you can hit the icon on the top right of the screen to bring up the “add word” screen again

When you’re done with your testing press the back button and exit out of the screen. Any items added to the list will be lost forever and the next time you return to Quick Test you’ll have the chance to load new words (again, area for improvement)

Let us know where you’re running into issues. If you’re noticing things not saving please let us know what words are causing troubles and we’ll have a look. Jeremy will have to do the investigating for the Japanese side of things since I’m only beginning to learn hiragana and katakana now (thanks, Skritter!), but we’ll get to the bottom of it and open up issues where necessary.

Thanks in advance and I hope this helps!

Thanks for the walkthrough on Quick Test. The issue I was running into it seems was that I was clicking Done when adding a word instead of pressing Enter. This causes the word not to actually be added to and loaded into the list. Your workaround of pressing Enter adds the word to the list and allows me to start testing. Thanks!

I really do like this feature and find a ton of value in it. I’d love to see Skritter keep the ability to create a “scratch list” like this so that I can practice things like names, practice stuff from my Anki deck, or practice some more advanced kanji, without necessarily having to create/add it to a list.

1 Like

Glad it worked. Like I said, it’s a bit rough at the moment, but we’ll keep working on improving it. Since deploying internally I’ve used it almost every day for one thing or another. I love it! Basically, we wanna keep it around, too. I think we’ll just be using the base code of loading writings in a list without SRS for lots of the other stuff in the future. Stay tuned!

Some Bugs…


  • I tried adding 繙く to Quick test, but I can’t study it - it just speeds past the word. Is this word not in your mapping table?

Quick Test

So have done a lot of Quick Test lately. Two major things that need to be improved:

  • Deleting a single word deletes the entire list of words. Whooops!! This is actually a pretty fatal flaw that would be nice to see fixed in the next snap, if possible.
  • Quitting Quick Test erases your current list. I’d love to see it preserve the list by default, and see a button added that supports wiping out the entire list and starting from scratch. (It’d also be nice to have custom Quick Test lists sometime in the future, but for now, preservation across sessions would be a huge win.)

My use case for list persistence: For new words or words I miss in Anki, it would be great to be able to add them to Quick Test so that I can study them a couple times throughout the day. This would make Anki + Skritter a great one-two combo: I could use Skritter to intensely study new words or words/kanji I’ve forgotten, and then use Anki for general recall.

EDIT: Actually, another use case for list persistence is the ability to hop between normal Skritter and Quick Test, so that I can add “troublesome” kanji to a list in Quick Test and drill on those words specifically throughout the day.

Another issue that seems pretty serious…

After spending a few days using the Beta, I notice that, when I check my Progress in Old Skritter, the app is telling me that I’ve only studied 6 kanji, and that I’ve neither added nor learned any new kanji. So basically, it looks like my kanji learning has totally flatlined. This seems way off - I know I’ve added new kanji, and it’s not plausible that my learning rate suddenly stopped. I don’t think New Skritter is communicating these statistics accurately to your back end.

Can someone take a look? This is a pretty fatal issue for me, and I’ll have to cease use of the Beta until it gets fixed.

EDIT: I went back to using Old Skritter, and I notice that words that were already added in New Skritter as “new” are showing up as “New” in Old Skritter as well, even though I’ve already added and started studying them to New Skritter. So I wonder if that’s a factor here…

Also, as an additional data point - checking my stats online also shows a complete flatline of kanji learning. So this appears to be a bug in Beta.

Thanks for the report! We’ll be looking into this issue this week and checking for sync stability on Japanese more. It might help to logout and login into the beta again, especially if you’ve been using though several versions.

I logged out and back in, and did 7 minutes of study. I got progress to sync on old skritter. Same issue - no movement in kanji rankings even though I know I added new kanji during the session. I did just two minutes in Old Skritter and saw changes in my stats. So there’s a real issue with sync on my phone with the beta app.

I’ll have to quit beta until this is fixed - I can’t not have my stats updating, as they’re key to me tracking my progress from week to week.

We appreciate the feedback and we’ll dig into it. My guess is that things are being saved but data is not displaying correctly between the beta and the other apps. We’ll have a look and work on patching things up more. Once we feel like we’ve addressed the issue we’ll let ya know!

Sorry the beta is giving you trouble. We appreciate all the feedback thus far and hope to have ya back soon!

3.0.13 is hosed on my iPhone 8 Plus. It let me do a few cards, then failed to advance to the next word. I restarted the app, and now it shows me a screen with a frozen time count, no word, and no drawing area for the kanji.

I’m getting that sometimes after upgrading to 13 as well. Maybe because I filtered down to just writing? Anyway, I could kickstart it again by turning all filters off, going back the main screen, and study, and turn all filters on again. Or something like that. But it happens again after awhile. Seems to be related to tapping / changing grades.

That’s likely why I hit it so quickly - writing is all I do on the Skritter app.

1 Like


We’ve retransferred your study data-- would you be able to:
1 delete app and reinstall
2 log in, and if the app fails on study screen, restart the app

Please let us know how this goes!

1 Like

There are certainly some crazy things happening in these builds as we try to figure out what the heck is happening with loops. As @Jeremy said to @Jay_Andrew_Allen might be a good idea to delete the app and load things up fresh and see if it helps.

If not, do let us know here and via email so we can keep trying crazy stuff. The good news is we’re starting to understand the situation a lot better, and at a certain point in the process, we just have to update the see what the heck happens.

I deleted the app, reinstalled, logged back in - same issue. I restarted my phone and restarted the app - no dice. I’m still stuck on a blank study screen with an unmoving timer :frowning:

Dang :frowning: Okay. Before we totally give up (to clarify, I just mean, admit that this build didn’t do the trick for your account) I have a few questions.

What happens when you try single list study, or, try adding items to the screen. Also, are any filters off right now? Does anything happen? I’m trying to figure out, without testing on your account, if there is a particular item that is stuck right now, or if the whole thing is just not loading correctly. Also, are you syncing on WiFi or a cell network? Shouldn’t make a difference, but I’m trying to think outside the box.

We’ll keep working on things. Have you been in touch with @josh via our team email? If you’re on iOS you can roll-back to a previous version of the app that was working for you until we deploy the next update.

I just emailed a video of it happening on my phone. After submitting that, I tried deleting and reinstalling the app. Upon restart, I got the blank screen again. However, after I worked around the blank screen by turning off all my filters and turning them on again, I was able to proceed and it hasn’t locked up again. Also, then I finally got the “怎麼辦” prompt that I was looping on in previous builds. I wonder if that was related.


So far it looks like rpetersn’s workaround got me unstuck. I’ll use throughout the day and report back with any issues.

This is wonderful news. We’re getting similar reports from most of the loopers we’re in contact with. Fingers crossed that we’ve passed this hurdle and can move on to more app updates that improve the rest of the experience!