No audio on new cards

Hi, it seems that any new cards I’m adding have no working audio. I am mainly adding off the HSK 2 (2021) deck.

All of my old cards added before I took a hiatus still play audio fine. Any new cards do not. On the learn screen if I hit the speaker button on the top right, nothing plays. The audio never plays in the review either. If I hit the speaker on the example sentence, that audio does play.

I already tried clearing the audio and image cache in my settings, but that did not work.

How can I fix this?

I am on Android Beta version 3.8.1 (3005835), but this was still happening on 3005833 (thought the update would help but no dice)

Hi, thanks for the report. We’re looking into some audio issues on Android that seem to have snuck in the past couple of beta builds.

Usually logging out and then logging back in fixes the issue. You can also try uninstalling and then reinstalling the app. Let us know at if you’re still experiencing the issue after trying this.

1 Like

Hey @SkritterMichael , thanks for the response! Logging out and in did not work, but uninstalling and reinstalling did. However, the very next day (today), the audio stopped working in the same way again. No audio playing for the cards at the top of my review deck. Uninstalling and reinstalling fixed it again, but of course that’s not feasible to do daily. Hopefully a fix can be issued?

We just released a patch on Android (version 3.8.3) that might fix this issue. After installing the patch update you’ll need to do one of two things:

  1. Refresh local data from within your account user settings
  2. Log out and back in to your account

It seems like one of our dependency updates might have been caching URL’s incorrectly on Android which means that things would appear fixed after a fresh log in but on the the next app open they would be broken due to loading the bad cached data. Keep an eye out on the Google Play Store for the new version as it should become available shortly.

Hey, studying the next day again and it looks like the audio is still working this time around. Thanks for the timely response and fix, much appreciated!