No items studied, no time studied

Not high on the list of issues to be addressed but the app is telling me I haven’t done any study today. (Checked on 2 devices)

Due count has gone down, cards are appearing and disappearing correctly (as far as I can tell) and I checked the stats on the legacy site and it shows 30mins of study. Just the app that’s displaying incorrectly.


I’m having the same issue. It was a bit unnerving, but as long as the due count is changing correctly I guess it’s fine.

this just happened to me today - annoying

does the problem fix itself in the beta app?
or is there something that can be done?

Same thing happening for me. Doesn’t show time studied or the goal mode items studied. However, the overall items due still shows though.

The data is still there. You can see it at . No doubt a change has had unexpected consequences. I imagine they’ll do a rollback or a fix over the next few days.

We’ve spotted this and are working on a fix. Sorry in the meantime everyone, and thanks for the heads up!

Hi everyone,

Just wanted to send out a quick updated as of March, 18th (3:50 PM (PDT). We can see the recent pattern change in the ProgressStats code that lines up with the reports we’ve been getting from you. As @mikemills mentioned, data is still there and is being stored, but isn’t displaying. We’ll continue to work on the fix. Hopefully, our next update is an all clear!


Update. Josh just pushed a fix live on the site and things are looking good from my end. Yesterday’s study progress appeared on my monthly heatmap and daily goal progress updated as well.

Please let us know if you’re still not seeing the fix so we can investigate further. For now, Josh and I are marking this issue as closed. Thanks for your patience while we got the bottom of it.

it’s fixed on the web client for me, but progress still isn’t displayed on the android beta app (both time and items studied is 0.)


When we likely to get an app update for this?

Though to be honest, having to bounce the app whenever you leave and return to the study page, and navigation using invisible buttons are more annoying than not having a daily item or minute count on the dashboard

Just to clarify - I know you guys have got your hands full at the moment and the iOS client needs to take precedence. Some feedback on where issues sit in your priority list would be good though. I know it’s impossible to commit to deliverable dates with a small team and this point in the chaos that is skritter V2 but some indication of whether we’re talking weeks, months or years on each issue would be good. (and I’m serious about ‘years’ - you’ve bitten off an enormous task building a complex system on multiple platforms to run on virtually any device. Complicated by user expectations of performance and functionality at least as good as the previous ios version that constrain your ability to deliver minimum viable product releases. I don’t envy you.

It’s still be good to know where issues sit in your priorities though. Communication is key when you’re struggling to meet user expectations.

The web site stats page is still telling me I haven’t studied today. Dashboard items count is ok.

FYI The performance degredation on drawing kanji is an issue on the web site too but not to nearly the same extent.

And just as a matter of interest, why do definition cards only show the answer when you press at the bottom while reading cards you can press anywhere?

The website is showing the correct stats/data for me now, but the Android app still is not - tested on both my Galaxy S5 phone and Galaxy Note 10.1 (2014) tablet. The sync button just spins forever and never does anything. I would use the website until the Android app is fixed, but my Intuos 5 refuses to work with it and there’s no way I’m going to try using the mouse! Godspeed, Skritter team! :slight_smile:

Hey guys,

Thanks for being patient. While we did a quick fix over the weekend, I just corrected the root cause of the stats issues a few hours ago. A recent dependency upgrade caused a subtle error to occur in one of our processes. Because of this, a copy of the data that we use to display the stats was being rejected when it shouldn’t have been. Tests for this issue have been written and emails to ping us as soon as something goes wrong in this area have been written. Any study time you do now should show up properly. It’ll take some time to re-propagate the older data that didn’t get transferred, so give it another 12 hours, and then it should be good. We didn’t update the beta mobile app with the quick fix we did for the website, which is why the stats still seem a little wonky. It should be fixed up in the next 12 hours when the missing gaps in the display data gets filled in.

Speaking of the beta mobile app, we’ve been pretty tight-lipped about it, but have been sinking a lot of time into fixing the major complaints (offline and syncing, performance on some devices, etc.) and taking some drastic actions to address them. Basically, we’ve significantly reworked the mobile app’s architecture and rewritten a large majority of the UI to work better on mobile. This was a big time investment and we knew it would mean delaying beta updates for a couple months. However, we’re getting close to a point where we want to give it to you all and get some feedback. I would say the next beta release is a matter of weeks or a month off. We’re planning to make an official post about it in the near future, so keep your eyes open for it.


I’ve done a bit of study today but I suspect this item count is just a tad high…


Bounced the app and it’s back to 112 which is much more likely

Works for me now on the web version. Thanks for fixing this as quick as you did!

counts are still really off on the Android app - i just reviewed at least 40 and the progress only indicates 19 in the Android app (and 75 in the web app which is probably the right number)

i understand this is beta but this shows a lack of internal QA for a product that we’re paying for and helping you develop by using the the beta instead of the legacy product - perhaps a subscription discount is in order for folks slogging through the bugs (because it’s making the app unhelpful or inconvenient as to tracking study progress)

edit… and after restarting the app it now shows 175 - bad numbers are worse than no numbers - at least with no numbers i knew it wasn’t working, now I’m never sure if the number is valid or not without checking the webapp

We did not end up re-transferring the data last night, so it will still be off until later today. Sorry about the delay. We were still receiving some backlogged notifications that were stuck in a message queue until late last night and wanted to monitor and verify that the problem had indeed been solved before starting to re-transfer any data (it was fixed, all the timestamps on the messages we received were from before the fix, none after). As it’s a decent chunk of data, it takes a while to transfer. We wanted to be certain the problem was fixed before initiating it so that we would only have to do it once. We have both manual and automated QA processes in place to help us deploy with confidence and test certain scenarios for breaking bugs, but the change which caused this missed the manual check because this error was caused by work in an unrelated area of the backend, and there was a configuration error which caused the relevant automated tests to be skipped.

As it is beta software and an opt-in program for mobile, occasional bugs and instability are to be expected. That being said, we’re happy to help compensate for interruptions to your study routine–you’re paying to study! So if your routine was interrupted by the stats not displaying correctly, email or PM me and we’ll make it right.


Looks like the numbers in the Android app are in sync with the webapp now. The stats backfilled themselves too, which is nice (for example, the calendar had been showing gaps despite the studying and now is filled in with the studying that was done). Thank you for all the work done to address this problem (both serverside and customerside).


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.