Skitter won't get past initial loading screen

Screen goes black after skitter logo. App stops loading.
Bought a new Nexus 6 to replace my old one.
I’m on the latest beta, but this happened the last time I got a new phone and I can’t remember how I fixed it…tried reinstalling, clearing app cache, force stopping, etc.

I’ve posted this on our support channel to see if anyone has any ideas. Expect something tomorrow when we’re all back at work for the week.

In the meantime, what OS are you on a the moment? Nexus 6 appears to be from November 2014 based on my googling, so it’ll be very hard to optimize our app for this device if something is going wrong. The fact that you got things running before is promising, so perhaps some Android peeps on here have a few ideas you could try.

In the meantime, here is a link to our APK files. We’ve still got the old 2.1.2 APK in there if you’d like to give it a go for now. Otherwise, you can use Chrome browser and login on and do your studying via our website.


It’s 7.1.1 and it is an identical phone to the one that is working, I don’t know if you guys output anything to the logcat but I’ll look at that tommorow.

1 Like

Thanks for the updated info!

Now it is loading to the simplified/traditional menu, so all is good.

Awesome! Glad to hear things are working again.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.