Sometimes reviews are zero

This is regarding the legacy app.

At times in advanced study individual lists load with zero reviews, although there should be hundreds.

I can anticipate when this is going to happen if the list loads immediately without the writing screen first going black - for a few seconds, sometimes for a few minutes. The photo above illustrates what has to happen before reviews will load.

If it goes black and I’m patient, I’ll have words to review. If not, I won’t.

Except sometimes it loads without the black screen, there are no cards to review, and if I review for about five minutes anyway, suddenly the review number jumps into the hundreds and I’ve finally got my algorithmic reviews.

This has been happening forever. I’ve never bothered to bring it up before, because the screen usually goes black. But it is very annoying when it just won’t. I turn the app on and off again, disconnect from Pleco, and sometimes that works, often it doesn’t.

Any fix or idea about this? Others having the same problem?

I’d like to see if I can reproduce this on my end. Is there any particular list you notice the black screen on when you’re using advanced study? It seems like it is trying to load up all the reviews and maybe it is failing from time to time, but I’d like to try and test it on similar decks as the ones you’re seeing the trouble on. Also, what phone are you studying on?

Thanks in advance!

All lists have the black screen - when it is working correctly, which it normally does. If they don’t start off with a black screen, then no reviews get loaded.

iPhone, latest update.

Thanks for looking into this.

Today I turned the app on and off a few times, left it alone for about 15 mins, turned it on again, and the black screen appeared, which is the sign that the reviews will load when it disappears, which they did. So today worked out. It’s not usually a problem.

Black screen takes anywhere from a few seconds to several minutes. Does this mean other people don’t get a black screen at all?

Which iPhone? You can check under the phones General Settings -> About -> Model Name if you’re unsure off the top of your head. I have access to two or three devices, but between me and the rest of the team we have a pretty good mix of phones to try. It is possible, for example, that a newer OS on and older phone is just loading slow, which sounds like it could be the case if some decks take minutes.

Do you toggle any additional settings when doing Advanced Study, or are you just selecting a deck?

I’ve seen a few black screens here and there, but it isn’t something that gets reported that often (I can’t recall the last report) so I’d like to gather a bit more info.

Thanks in advance!

Interesting. It’s always happened so I just assumed it was part of the app.

iPhone 8+

No special settings: just advanced study, then I pick a current list. Try Du 2019 11 November or Du 2019 11 November ADVANCED

I do study both traditional and simplified at the same time, if that makes a difference.

Thanks for this

Edit: actually, to ensure there are words to review, better to try any list except the ones I mentioned above, as they are current.

Another edit: a clue if it helps. Happened again today, not for my current (November) lists but afterwards, when I tried reviewing the October and September lists. No black screen; no words to review.

So I tried something new: I went to normal study (which I normally avoid because there are thousands of reviews waiting). There, only 8 reviews loaded, but at least I had a review number. Then ten loaded. Also not the accurate number. But after reviewing those ten I exited study and went back to advanced study, hoping the review loading in “study” had triggered something.

It did. Now the older lists are also showing black screens, which momentarily resulted in my review number.

Hope this helps. I’ll try anything that seems to “trigger” the review loading.

Thanks!

I actually loaded up your account on my device late last night, and right away (after about an hour and a half of syncing) I could tell what the issue is. You’ve reached epic status!

You have over 100k items, and 170 lists on your account, and ~48k due reviews. That is a lot of stuff, and the app is working hard to make the magic happen.

The database that Skritter stuff is stored in is kinda old by today’s standards (especially the way this iOS app is running things). So, any time you’re loading up lists like this the app is trying to sort through all your items and see what is due, and what isn’t. List size probably don’t matter much, but it is has to loop through the entire list items and then match it against your reviews so I would expect larger lists to take longer. Additionally, it has to talk to our server to do this, so you’re also in a queue with other people, which can also cause slower loading times if tons of people are studying at the same time. Also, since it is not calculated on the device, it can be prone to errors, which could be why you’re seeing the app not return anything sometimes.

Your device, although not terribly old, is also probably not helping things. Apple’s recent OS updates are mostly optimized for the new phones, and they can be taxing on older devices by themselves. While I didn’t do any studying on your account, I did load up a few lists on my iPhone X and it took a little bit of time to filter through things. Using the general study button did load something like 46k items, but it also took a while.

There isn’t really anything that we’re able to do in Skritter Chinese app to improve this. However, the good news is that I was able to load your account in seven minutes in the new app, and some quick tests of deck level testing appeared to be working okay. I know that you’re looking for mnemonics on study cards, and some other things to really make the experience better for the way your’e studying (and we’re working on some of that stuff), but I do think that you’re going to find that Skritter: Write Chinese will do a much better job handling an account of this size, if only for the fact that we’re using some much more modern ways to storing and sorting through data.

If you’re set on using Skritter Chinese app on iOS for the time being, I would recommend going into “Study” to force items to load into review. It should help, as it sounds like you noticed. I’d recommend doing that before you’re doing Advanced Study for the day, even if you don’t intend studying all items from all decks in one go.

Best,
Jake

1 Like

Thanks for so much effort for a single account!

Ok, will do: I’ll “trigger” the review loading process by going into study mode first.

Sheepishly, I really should delete some ancient custom lists. I have probably re-entered most of their words into more current lists, and if not, then they contain words I’m just not encountering anyway. That would probably make things much more efficient.

Also: just sent you an email about some quirky stats. Issue is not urgent! Just thought you should know something is off there.

Looking forward to using the new app one day. But waiting for all the prized features of the legacy app to transfer, as you promised they eventually would. Till then, happy to put up with the cranky but highly efficient OG app.

1 Like