Touchscreen / stylet input not working (PC)

Hello,
Since yesterday, I can’t input any stroke in the Skritter frame.
I’m using a surface pro 4 with touchscreen and stylet. These 2 inputs are not working anymore. Of course, any other app work just fine, so the problem is with Skritter. The weird thing is I can click with my finger or stylet on the icons (to show the pinyin, definition, show the character, show the stroke order, etc.) but impossible to input any stroke.
I also installed adobe flash and restarded my computer, tried another web browser, tried Skritter 1.0. Nothing helped.
So Skritter dev team, have you changed something in the code ? is there any way to solve this issue ? i really can’t work with the trackpad or mouse to write characters :confused:

cheers

Hi Elchouv, I just did some studying on my Surface Pro 4 with both pen and finger input on the regular skritter.com website and didn’t have any problems. The new website doesn’t use Flash, so you shouldn’t need to worry about that. We also haven’t made any updates to the writing canvas code on the website recently.
Which browser (and version of the browser) were you using to study?

1 Like

Hello Michael,
thank you for your reply.
I use Firefox v67.0 (64 bits) and it was working fine until now.
I also tried chrome Version 74.0.3729.169, same issue.
I retryed to use the stylet on photo editing softwares and Onenote, the stylet works perfectly (pressure included).
I don’t recall any update of web browsers, win10 or any driver that happened prior to the bug.
That’s really strange, do you have any idea of what could be the cause ?

1 Like

I’m on the exact same version of Chrome as you and my pen/touch input works :grimacing: However, I do see the problem in the latest version of Firefox. I will look into it and give you a status update soon. Thank you for the details!

Thanks for the support. I’ve made a video of the issue. You can see the input problem is only for the strokes, not the “tap on screen” action.
Here’s the video
Looking forward any news on this topic :wink:

Hey, good news, I got this working again! Go ahead and try it out (you may need to clear your browser’s cache)!

The issue was a bug in touch detection for our graphics library. A recent update to Firefox removed support for some features the library used to detect if touch was enabled. My research suggests pen/touch support should have broken in Chrome as well, but for some reason, it kept working on my machine. :man_shrugging:

In any event, things should be back to normal on your Surface, I tested writing prompts on the .com website in Chrome, Firefox, Firefox Nightly, and Edge. Happy studies!

AWESOME ! it’s working now !
thanks a lot for your support and for the explanations.
I wish you good luck for the ongoing developments :slight_smile:

1 Like

This is encouraging! I have a Surface Book 2 and have never been able to get the stylus or touch input to work on the website. The symptoms are the same as OP showed in his video. Likewise the stylus is working in other applications. I am using Chrome 75.0.3770.80 and also tried Edge with no success today. Any suggestions on what to try next?