Skritter: Write Chinese Beta Released!


#1

Hey guys, we’ve submitted a beta for Skritter Chinese to the iOS App Store and as I write this, we are awaiting approval! It should be available for download within the next few hours/days! You can sign up for the beta here: https://testflight.apple.com/join/xZGMuuNx

We’ve made a small video explaining some of the new features that you can watch here: https://www.youtube.com/watch?v=aEelmBcDREM

Here’s a some tips to help you get oriented to the larger changes:

  • We’ve renamed “vocab lists” to “decks” since with this new app, you can study the vocabulary in a more flexible order–not just start to finish. Thus, the term “list” isn’t as accurate anymore.

  • We’ve removed auto-item adding (and a magical “+” button to add items altogether!). To add items, choose the list (“deck”)/section you want to add from, and complete the “learn” activity. It will introduce up to 5 new vocabs and teach you how to write them (first in teaching mode, then in stroke snapping mode, and finally a boss fight in raw squigs). If you already know how to write the vocab and just want it added to your review queue, you can skip this process.

  • The optimal flow is first to learn some new vocabulary, then use the test activity to make sure you really know it, and finally go through your review queue to make sure you remember it long term. Don’t overstudy your review queue anymore when you want to learn a new chapter or section of something–test yourself! The SRS review activity now serves its real purpose–to review material you’ve already encountered, not teach you new material.

  • Progress only tracks classic review-based stats. It’s unfortunately confusing that we’ve got “learn-activity learned” and “review-activity learned” right now, it’s an area we are working to improve. So even if you learn 5 new words from the learn activity, they won’t affect your stats until you’ve reviewed them correctly a couple times, just like Skritter’s always tracked stats. You can think of the green check mark next to vocabs as “added to review queue”–not necessarily an indication of how well you know the vocab. In the future we will improve this indication and visualization of your learning progress.

Please post any feedback or bugs you find here on the forum or email support@skritter.com for account-related issues. We look forward to hearing from you!


#2

I got a problem with the syncing process. It won’t finish.


#3

I also had the same problem…had to force-close the app and then restart it. Then the sync finished.


#4

Credential management isn’t working the way most iOS apps should work with the password keychain.

So, there are two minor issues with the Apple Keychain management on this app:
1). Passwords being blanked out
2). Keychain entries not being mapped to the app.

Details:

The first time I launched the Beta, it didn’t recognize this as able to use the “Skritter” entry from my saved passwords…that’s fine for the first launch.

So, I went into my keychain, instead of entering my Skritter credentials manually, and selected the Skritter keychain item.

The keychain then auto filled both the username and password correctly.

But when I hit the button to log in, Skritter “blanked out” the password even though the Keychain had added both a username and password and gave me an error saying that I needed to input a password.

I then did it again, but this time clicked on the password entry box after the Keychain. Skritter again blanked it out, but I used the Keychain manager to put the password in while in the password box.

This time it worked and logged me in ok.

I then logged out of Skritter Beta, and shut it down.

I then went back into the Beta, and expected Skritter Beta to now be recognized by the Keychain…no such luck…it didn’t auto suggest that this password should be used from the Keychain (most other apps autorecognize this).

And again, when I tried to auto fill the credentials by selecting the Keychain entry manually, it did the same “blank out the password after the Keychain manager filled it in”.


#5

Yes I can also confirm this bug.
What I also just experienced is, that when I click on “My Words” at the bottom right, it is trying to load the data, but never exceeds 0 % and then it crashes and goes back to “Home”.

Further, when tones are asked, the app automatically speaks out the word loudly even before I can give my answer. Hence, I can easily get the solution without necessarily know the answer beforehand.

Lastly, I actually miss the 2 sounds whenever I give a correct or incorrect answer. It is a minor thing, but I got really used to it and find it somewhat “satisfying” when having a right answer.

One more thing: I would like to see the example sentence at the front page. I find it rather uncomfortable to tap at the upper right information toggle to see the sentence. I would like to see an implementation similar to the legacy app. Or you could put the sentence underneath the character


#6

Hi there :slight_smile: My first post here.

I like the look and feel of the new Beta. For me, it looks more mature than the previous ones. But besides the already postet ones, there are some severe issues on my iPhone X with iOS 12.1.4:

  • The auto advance option disappeared
  • The language is set to “Deutsch” (why “Deutsch” and not “German”?). But the cards are displayed in English
  • I can’t change the language. Even if I try to switch it to an other language than “Deutsch”, the setting resets itself to “Deutsch” after a second or so


#7

Congratulations on the new beta release! It has obviously been a lot of work.

I’ll cover just one thing – the app becomes unusably slow sometimes when writing characters.

I am on iOS, iPhone X, beta 3.1.4 (300158). There are several parts of the app that are way too slow, especially loading the review screen, anything related to My Words, loading any of the deck screens, etc. But I’m not talking about that.

My problem is that after writing a few characters, writing gets very slow, and sometimes the app gets so slow that it appears unresponsive. Killing the app and restarting fixes it temporarily. It happens for sure when I hit the back button (see steps below). I tried avoiding the back button and it still happened, so maybe there are other times too, but I didn’t repro them.

This is a big impact on my usage as I find I often hit that button forgetting it breaks everything.

I can repro this by:

  1. Kill and restart the app
  2. Go into the Review section by hitting the button at the top of the dashboard
  3. Select Writing and not the other card types (not sure if this matters, but I always review by card type)
  4. Hit Start Review
  5. Review some cards. Observe that writing is sufficiently fast.
  6. Hit the back arrow to see a previous card.
  7. Go to the next card and try writing again

Expect: writing is sufficiently fast
Observe: writing becomes super slow, and stays this way until it is killed and restarted.


#8

On my iPad Pro 11” (2018 version), the top and bottom of the screen are cut off. You can see the word “Home” has the top of the lettering cut off and the 3-bar (hamburger) menu has the top bar cut off. Additionally, the “swipe up bar” at the bottom covers the icons.

Also, is the Landscape mode coming back? It doesn’t work any longer…just Portrait mode works.

Here’s what I see:


#9

The introduction video pops up repeatedly, even after tapping “ok cool”, I can’t access anything but that video.


#10

If I view a list with a lot of sections in it, I may have to scroll down quite a bit to get to the section I want. If I then select a section and view the words, when I hit the back button (to leave the detailed word list), it returns back to the top of the section listing…it would be better to return to the same scroll position as I had when I viewed the section.

Did that make sense?


#11

Custom definitions created for items aren’t showing up on the main review definition headings when presented with a character prompt. I see my custom definition if I press the “i” button, but it doesn’t appear in the prompt.

Here’s an example: (I added “imagination” and took out the “in traditional, use…” text)


#12

1). Weird font in the ǎ of xiǎng。it’s bigger than the surrounding characters.

2). And here the ǎ is smaller

3). Also, I have this word banned, but it still popped up as a review item. Pressing the “i” button shows it’s banned with the red-circle-slash.

4). There is also no way to “skip” this banned writing prompt (in 3 above). The “Forgot/Got it” buttons didn’t appear until I wrote out the full character. So, I had to write out all three 汉字 before I could move on.

5). Really missing the “automatically advance” here…tapping on every item to advance to the next feels like a step back on Usability. It felt so clean in the Classic iOS client.

6). Spacing on iPad Pro is poor. Extreme amounts of white space.

7). Really have to reach FAR to get between the “forgot/got it” buttons and the “back” arrow and the “i” definition (and to get to Pleco). They are more than 9 inches apart diagonally.

8). Left-handed mode needed.

9). Dark mode is needed…especially due to (6) with the huge amounts of white space.

10). Hitting the back-arrow to return to a writing prompt doesn’t show the character. As shown here:

11). I really like that the “i” info shows what list a word came from!

12). I really enjoy that the teapot makes steam.

13). Is there a way to hide PinYin when a tone prompt appears? I just “should” be presented with a character.

14). Sometimes “tone” prompts come up with a blank drawing screen, making the user think it is a writing prompt, which usually causes the failure of the card. The character immediately “appears” after the correct tone is displayed.

15). When you go back to a previous item and change the grade, it jumps ahead to the next item before you can visually confirm the grade “color” changed. (I.e. the advancing from tapping a grade button is so fast that the user gets no confirmation feedback that the grade was changed)

16). I’m still not sure on the lack of a “so-so” (Yellow) grade button. How is the SRS going to change in response to only having two grades? I used this Yellow grade a lot, because when I’d give items a few Green grades, the seemed to never show up until long past the time I forgot them. I no longer see a retention rate (95%, 98%, etc) setting, so there appears to be no knob to turn to tell the SRS “I forget things easily, so show them more frequently”.

17). How do I look at Decks that I’ve made, but currently am not studying. The Deck’s “My Library” doesn’t show old decks that I’ve made but am not studying. Searching under “Browse” for these decks by partial name string yielded no results.

18). How do I create a new deck?

19). What does “Download Deck” do? Without using this button, I can already see the words I’m studying in the deck and can open up sections of the deck. What does this button do?

20). Searching for a deck in “My Library” displays an incorrect message when it doesn’t find a matching deck as per this picture:
(I searched for “Green”, but don’t have any decks with that in the name)

21). I’ve spent a few hours (real clock time) on new Skritter, but all of my reviews were of about 20 or so characters that I recently added. They just kept coming up again and again and again. None of the older characters I’ve added came up. However, in all that time spent, My review queue in that time only went down from about 600 items to 500 items. On old Skritter, in that same amount of time, I would have taken my review queue down to around 200 or less. So, the SRS “feels” different, or is broken…not sure which.


#13
  • As a big fan of 1password, this is also a feature I would like to see keychain auto-filling, however, it’s further down the list of priorities at the moment, but something we will get to.
  • In this initial release, we are focusing on phones, so the app is not optimized for iPads as of yet, That being said, we will look at fixing the issue of the bottom and top parts being cut off. We also hope to bring back landscape mode in the near future.

Yes. This is something we can try and improve after some of the higher priority things.

This should be an easy fix to do, and we’ll try and get that added in the next couple of builds.

We hope to bring back auto-advance very soon.

I’m left-handed also, so this is something we would like to add a bit later on. See my previous point about ipad optimization.

There is dark mode in the settings, but it’s not perfect…just yet.

Michael added this just a few days ago. We’re glad you appreciate it.

We hope to re-add this to the app in the near future.

This is one of my additions to the app. I’m glad you like it.

Thanks for all the feedback. We’re currently collecting and prioritizing it all, and will be updating the app regularly to make all of your studying easier.


#14

This should be fixed as of build 3.1.4 (300161). Sorry to be annoying.


#15

Downloading a deck allows you to study the deck (LEARN/TEST), and begin add it to your REVIEW cue. It will also add to “My Library” once you begin actively studying it.


#16

@Gwilym. Shouldn’t decks ALREADY in you “My Library” automatically “Download Deck” for you? All of the decks currently in My Library still had the “Download Deck button”.

Conversely, I just downloaded the NPCR deck, and it took a few minutes…so maybe that’s why they aren’t auto-downloading.

BTW: I never would have realized that learn/test was enabled by hitting the Download Deck button. Might be good to clarify that somewhere in the app.


#17

This should be fixed as of 3.1.4 (300161)


#18

I actually am using that version: 3.1.4 (300161) Sorry, I should have included my version number originally.


#19

How long should it take after Learning new words that they show up in Review? None of the new words I have learned using Learn are in Review. Or do I have to Test first?


#20

The position of the information where a word comes from should be changed a bit. On the iPhone X it is at the very bottom, almost not visible due to the swipe up line.